Mesh 5.0 is here!


#145

Ordinarily, once you have updated the user interface app on your phone to 5.0, then a button should appear under Settings>Device Information. Pushing the button should activate the download of the 1.1.8 firmware via Bluetooth to your goTenna mesh unit.

Your serial number is not in the AA12341234 group, so the update should work, but since an Android is involved, things are sometimes still a little more complicated. Check Virginia’s recent message for more detail, then drop her a line if that doesn’t resolve things.

Note this is not because Android is “bad” or that iPhone js “better.” The ecosystems are just different. Apple keeps everything in line under one roof, it’s own rules govern and are uniformly applied.

With Android, every mfg takes the basic functionality, then implements it how they see fit. Samsung is particularly notorious in this regard. Since there are probably hundreds of different “flavors” of Android, goTenna tries to cover them all. Testing all is probably beyond anyone’s capacity. So there’s a certain amount of “user testing” inherent in almost anyone’s Android updates, because some things slip through because of the lack of “central management” of Android like Apple does with the iOS. What counts is how responsive goTenna is in following up addressing the irritations are they come up in use.

Yes, when many people contribute to the discussion, if can diverge and fork, but its also useful. Your problem is not someone else’s problems and they all must be covered. There’s isn’t a single concise solution here, as the problems involved vary.


#146

Sent you a message to help with updating!


#147

I am having the same problem.


#148

I also have firmware version 0.13.48 and unable to update.


#149

Angela,
Which phone and OS are you using?
Can you confirm what the serial number is?


#150

Mike, the problem is not only with the AA12341234 and in fact the worst problems, the ones where the units fail to update after reaching 100%, seem to be with MX units. 2 of mine have the worst problem, the last one Virginia mentioned, “Unit fails update, LED out”. I suspect a third one also has it. A fourth one that I had exchanged later on updated fine, also MX. There are several different problems with different serial numbers, probably depends on which batch or internal version.


#151

FWIW, I also have at least one MX171 which is not prompting for update. Unfortunately I couldn’t get the exact serials of the other two which failed to update before “bricking” them (it’s not an actual brick, they turn on and off, just don’t pair), but I know they were MX and I think they’re probably also MX171. First with Android it wasn’t giving me the option to upgrade firmware, then I tried in iOS, which did run the update, but ultimately failed, leading to them not pairing anymore. I exchanged a fourth one after the original developed a power button issue, and the exchanged one is MX173, and that one updated fine.


#152

Andy,
There may be other than AA12341234 failing in the update somehow, but I suspect these should mostly turn out OK once recovered.

All the units I updated were MX with the exception of a GT or two.

When they do hit the brick wall and you’ve tried the tips Virginia mentioned, contact her and they will followup. That’s what can be fixed, it’s certain to correct things, and it’ll work better in future editions.


#153

I believe these failing MX units are the worst affected, I’m having to send mine in for replacement. I’ve already gone through the process with support so just a heads up for people who haven’t updated theirs yet, better to wait until we have more info on which MX units are updateable.


#154

By the way, when did you buy yours, and which are the 3 or 4 digits after “MX”?


#155

My MX170 is one not promping the blue button for upgrade. an interesting side note the replacement I recived is 12341234 but factory loaded with the 1.1.8firmware.


#156

The 5.0.1 updates seem to be detecting the non-upgradeable units. The Android app pops up a notification saying the firmware update is not applicable to the unit and to contact support. The iOS app doesn’t pop up that message, but doesn’t have the “update” button anymore.


#157

This is what I see when selecting “Settings - About”:


#158

I started messing with mesh back in December. Everything I have specifically goTenna - I have lots of “parts” from other radios - was acquired since then. There’s a used component to a part of our fleet, so a few may be older.

Just to clear up something for me as an old inventory guy and because I think when I see references to “Serial Number” here by goTenna Staff, it’s always to the 2-letter, 8-number number that is found via Settings>Support>About in electronic form in the user app.

The references here to shorter serial numbers or possibly coded model numbers sounds like it is to labeling on the box. Once the item is out of the box, I’m not sure how other than the app to come up with a consistent read of an individual unit number other than the internal one. Thus I’m pretty sure that goTenna is referring to this electronically generated serial number. That’s what I’m referring to anyway.

The bulk of our inventory is MX with 8 digit serials, all updated and either in service or waiting to go up into stationary nodes as those are swapped down for updating. There is a GT prefixed unit or two, but I think they’re currently up in a node so can’t say on those.

We have 5 AA12341234 on hand and an estimated 2 more still up in nodes. These will be dealt with later.


#159

Yes, I’m sure the 5.0 firmware works on the AA12341234 units just fine based on experience here. The issue is the distribution system, designed for different serial numbered items, which gets a sense of deja vu when it starts seeing the same numbers.


#160

The references here to shorter serial numbers or possibly coded model numbers sounds like it is to labeling on the box.

We’re referring to the same number, we’re just typing the first 3 digits after MX.


#161

I have two black mesh MX171 units from the kickstarter that updated fine (though it took well over 25 minutes for both), but my green MX173 kickstarter unit is getting a “update not supported” prompt.


#162

A half hour or so for the update is pretty typical.

What phone do you have paired with this unit? The goTennas should update, but if linked to a phone that is no longer supported, that message would make sense.


#163

Tried the update from both an iPhone X and iPhone 6Plus running iOS 11.4.1. Also running Gotenna App version 5.0.1. I believe the serial numbers started with MX171. I am sending 4 units back to Gotenna and receiving replacements. Virginia has been very helpful.


#164

Happy to hear that it’s working out. For most folks this works and we never hear a thing. But for those who haven’t been that lucky, things will eventually be put right.